Fehler "BA727 Die ausgewählte VSS-Komponente ist nicht vorhanden: WIDWriter"

In diesem Artikel zeigen wir Lösungsansätze für unser Windows-Backup-Produkt BackupAssist Classic.

Problem:
Bei der Systemsicherung mit BackupAssist werden automatisch wichtige VSS-Writer in die Sicherung mit einbezogen. Ob und wie diese das Backup daraufhin bereitstellen, passiert außerhalb von BackupAssist. Deren Ursache ist somit in den jeweiligen Diensten zu suchen. Hierbei gibt es häufiger Fehler mit dem WIDWriter von Microsoft:

BA727 Die ausgewählte VSS-Komponente ist nicht vorhanden: WIDWriter

Ursache:
Einer der problematischen Dienste ist hierbei der sogenannte "WIDWriter", welcher in Windows Servern als Teil des Windows Internal Database (WID) bzw. bei Installation der WSUS-Rolle mit installiert wird.
Hierbei kommt es häufiger vor, dass der WID-Dienst trotz WSUS-Deinstallation fehlerhaft fortbesteht.

Lösung:
Das Problem kann durch die Deaktivierung des WID-Writers behoben werden. Sie sollten dennoch prüfen, ob der WID aktiv genutzt wird bzw. ob er überhaupt benötigt wird und ggf. das Feature deinstallieren.

We installed the WSUS service and then uninstalled it.  When we did this it installed the Windows Internal Database (WID) which is not removed when you uninstall WSUS.  Somehow this service got started and was causing the problem. I believe that it is linked to the Remote Access Service which is what started up the service.  If we do a back-up with this service running we get the inconsistent error.  If the service is stopped, then we get successful backups without the error.
https://social.technet.microsoft.com/Forums/office/en-US/563505ab-4e9d-4adb-9aa2-f2b02bce8b19/backup-successful-but-inconsistent?forum=winserveressentials