Die Installation der BackupAssist MSI schlägt fehl

Problem:
Die Installation von BackupAssist schlägt fehl mit dem Fehler "Der Assistent wurde unterbrochen, bevor die Installation abgeschlossen werden konnte. De- oder Installation schlägt fehl.". 

Ursache:
Dieses Problem kann während der Installation von BackupAssist, wenn folgende Bedingungen erfüllt sind: 
  • Die Windows Installer-Dateien sind entweder beschädigt oder nicht vorhanden. 
  • Eine De- oder Installation einer Anwendung, die den Windows-Installer bzw. eine .msi-Paketdatei verwendet, schlägt fehl. 

Lösung 1: Den Windows Installer neu registrieren
Entfernen Sie den Windows Installer-Dienst aus der Registrierung und registrieren Sie ihn neu, um die entsprechenden Einträge zu korrigieren. Der Dienst wird daraufhin beendet und neu registriert. So wird sichergestellt, dass der Windows-Installer wieder richtig funktioniert. 

Führen Sie dazu bitte die folgenden Schritte durch:
  • Führen Sie in einer Eingabeaufforderung (cmd.exe) den folgenden Befehl aus:
msiexec /unregister

  • Nehmen Sie danach einen Neustart des Systems vor 
  • Führen Sie nach dem Neustart erneut in einer Eingabeaufforderung den folgenden Befehl aus: 

msiexec /regserver 

Die oben beschriebene Vorgehensweise behebt die meisten Probleme in Situationen, in denen der Windows Installer nicht reagiert oder beschädigt ist. 

Lösung 2: Die Systemeinstellungen für 'msiexec.exe' prüfen
Falls das Problem durch die korrekte Registrierung des Windows Installers nicht behoben werden konnte, sollte Folgendes getan werden:
  1. Überprüfen Sie den Verzeichnispfad der Datei 'msiexec.exe' 
    1. Die genannte Datei sollte im Pfad "C:\Windows\system32\msiexec.exe" liegen 
  2. Prüfen Sie die Pfadangabe der Datei 'msiexec.exe' in der Windows-Registrierung: 
    1. Öffnen Sie den Registrierungs-Editor (regedit.exe) 
    2. Öffnen Sie folgenden Registrierungsschlüssel: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer


    3. Die Standard-Zeichenfolge des Schlüssels:


    4. Doppelklicken Sie im rechten Fenster auf "ImagePath". 
    5. Stellen Sie im Dialogfeld "Zeichenfolge bearbeiten" sicher, dass die Zeichenfolge im Feld "Wert" den korrekten Pfad zur Datei "Msiexec.exe" auf Ihrer Festplatte enthält. 
    6. Wenn sich die Datei "Msiexec.exe" im Ordner "C:\Windows\System32\" befindet, lautet der korrekte Pfad von "Msiexec.exe" im Feld Wert:

      C:\Windows\System32\Msiexec.exe /V
                      
    7. Wenn das Feld "Wert" nicht den o.g. Pfad enthält, müssen Sie diesen wie im Screenshot anpassen.