MDaemon Email Server: "Prozess CFENGINE.EXE konnte nicht gestartet werden" / "Error or timeout during Spam Filter processing"

Problem:
Es werden keine eingehenden und teilweise keine ausgehenden E-Mails auf dem MDaemon Email Server verarbeitet. Diese stauen sich in der "lokalen Warteschlange". Auch erneute Verarbeitungsversuche durch das Verschieben in die "Wiederholungs-Warteschlange" schafft keine Abhilfe.

Im \MDaemon\Logs\System.log findet sich folgender Fehler:
**** ALERT **** Prozess CFENGINE.EXE konnte nicht gestartet werden; Nachrichten können in die Warteschlangen verteilt, aber nicht zugestellt werden (Fehlerpunkt: 1, Fehler: 20) [EvProcess]
Im MDaemon\Logs\SMTP(eingehend).log findet sich der Fehler
Error or timeout during Spam Filter processing
Im Application-Event-Log findet sich folgender Fehler:
**** ALERT **** Spam Filter did not respond within expected time limit; CFEngine may have stopped responding; it will be stopped and restarted [EvProcess]

Ursache:
Ursache hierfür ist ein AV-Programm, dass die CFengine.exe aus dem \MDaemon\App-Pfad löscht/in Quarantäne verschiebt. Dadurch können die E-Mails nicht mehr auf SPAM oder Inhalte geprüft werden, und deren Verarbeitung wird eingestellt. Besonders anfällig hierfür ist der Windows Defender, da dieser erst seit Kurzem die SPAM- und Inhaltsfilter von MDaemon als Schadsoftware erkennt, sobald diese SPAM-Mails bzw. Anhänge mit Schadsoftware verarbeiten.

Ein Auszug aus dem Windows Defender Log:


Lösung:
Bitte setzen Sie Ausnahmen in Ihrem Antivirus auf das gesamte \MDaemon\-Verzeichnis und nehmen Sie die Dateien \MDaemon\App\CFengine.exe und \MDaemon\App\MDaemon.exe explizit in die Prozess-Ausnahmen auf.